Render.ru

Задержка при перерисовке вьюпорта

Рейтинг
31
#1
3ds max 2015 Design SP3. Обнаружилась неприятная вещь. При развёрнутом на весь экран вьюпорте (разрешение экрана 2560х1600) тормозит перерисовка вьюпорта после pan/zoom. Зажимаю среднюю кнопку мыши и начинаю таскать модель - всё летает; отпускаю кнопку и тут же снова зажимаю и пытаюсь перетащить модель - задержка 1-3 секунды, потом модель снова начинает легко перемещаться. С зумом, в общем, аналогично. Но при зуме колесом увеличение/уменьшение не плавное, а рывком в конечное состояние. Наличие модели не обязательно - можно просто любоваться координатной сеткой. WTF?

От драйвера (DirectX/Nitrous/OpenGL) эффект не зависит.

На том же компе 3ds max 2014 Design SP5 с Nitrous такого эффекта нет.

Когда-то, на другой версии Макса я с чем-то подобным сталкивался. Но как проблема была решена совершенно не помню :( Давно это было.

И ещё одна странность. Версия 2014 работает с драйвером Nitrous (Direct3D 11.0 Feature Level 10), а версия 2015 - с Nitrous (Direct3D 9.0). Т.е. 2015-й почему-то не хочет использовать возможности Direct3D 11. Это у всех так? Или только мне повезло?
 
Рейтинг
280
#2
у меня все норм - gtx 570. Может, драйвера обновить?
не ноут/комп случаем с двойной видюхой (intel - nvidia)? Может, под макс используется интегрированная?
 
Рейтинг
31
#3
Драйвера видеокарты - самые свежие. Интегрированного видео нет. Сама видеокарточка, правда, не ахти, но с 2014-ым Максом проблем-то нет.
 
Рейтинг
165
#4
У меня такая штука была и в 2010, и в 2013 до сих пор происходит периодически. Опытным путём было замечено, что такое происходит только при зажатии скролла на мыши (микрозадержка на 1.5 -2 секунды), а если выбрать иконку с ладошкой и подвигать сцену, то всё нормально. До сих пор не ясно, из-за чего это происходит, но интуиция подсказывает, что начинает это происходить после переключения вида с камеры на перспективу. Есть так же предположение, что это связано с откликом моей игровой мыши Logitech Performance MX, так как и дома и на работе пользуюсь такой.
 
Рейтинг
31
#5
Проблема решена. Всем спасибо за участие.

Решилось убиением 3dsmax.ini. Конечно было бы неплохо выяснить какой параметр отвечает за баг...
 
Рейтинг
165
#6
Проблема решена. Всем спасибо за участие.

Решилось убиением 3dsmax.ini. Конечно было бы неплохо выяснить какой параметр отвечает за баг...
Так ты просто удалил этот файл и всё? Или заменил его другим?
 
Рейтинг
165
#8
Ок, я попробую. Если это решит проблему с задержкой вьюпорта, то способ нужно будет вписать в книгу типсов и трипсов.
 
Сверху