Render.ru

Вертексы ведут себя странно при extrude всего объекта

Vas Ubito

Пользователь сайта
Рейтинг
2
#1
Когда делаю extrude для всей модели или для всех полигонов модели, то вертексы разлетаются в стороны. Их можно поправлять вручную, но это очень долго и муторно. Как это исправить? Кто-нибудь с таким сталкивался?
 

Вложения

Vas Ubito

Пользователь сайта
Рейтинг
2
#2
Пробовал удаление истории, freeze transformation, конвертирование в obj и fbx с обратным возвращением в маю. Ничего не помогает
 

Vas Ubito

Пользователь сайта
Рейтинг
2
#4
2018-го года maya, а меш самый обычный, я его создавал с нуля, а не скачивал. И это повторяется не первый раз, по этому не в нём дело
 

Nevajno

Знаток
Рейтинг
27
#8
Скорее всего дело не в версии Майи, а в ошибках моделирования. Попробуйте применить cleanup, для устранения типичных ошибок.
 

Vas Ubito

Пользователь сайта
Рейтинг
2
#9
Скорее всего дело не в версии Майи, а в ошибках моделирования. Попробуйте применить cleanup, для устранения типичных ошибок.
я понимаю о чём вы говорите, но проблем с сеткой никаких нету. Даже топология везде квадратами. Это просто вертексы, которые при экструде улетаеют куда-то далеко
 

Nevajno

Знаток
Рейтинг
27
#10
я понимаю о чём вы говорите, но проблем с сеткой никаких нету. Даже топология везде квадратами. Это просто вертексы, которые при экструде улетаеют куда-то далеко
Проблемы есть, раз уж так разлетаются вертексы - сам по себе инструмент вполне стабильно работает.
Для начала я бы развернул нормали. Видно, что это задняя сторона поверхности. Попробуй применить Set to Face (потом можно снова нормали сгладить).
 

Vas Ubito

Пользователь сайта
Рейтинг
2
#11
Проблемы есть, раз уж так разлетаются вертексы - сам по себе инструмент вполне стабильно работает.
Для начала я бы развернул нормали. Видно, что это задняя сторона поверхности. Попробуй применить Set to Face (потом можно снова нормали сгладить).
Это не задняя сторона, это после применения экструда во внутреннюю сторону полигоны переворачиваются. Если экструдить нормально во внешнюю сторону, то вертексы будут улетать так же. И скорее всего какая-то проблема есть, но сами полигоны только созданы и у них нет проблем, потому что модель была очень низкополигональна и после применения 1 итерации смуза не было выявлено никаких проблем с мешем. Я к тому что cleаn up не помог и я сомневаюсь что поможет set to face. Скорее всего то баг или проблема с историей меша, хотя я её чистил. Но я попробую последний вариант. Спасибо
 
Сверху