Render.ru

Искажение normal map при деформации модели

Ro:nin

Активный участник
Рейтинг
15
#1
Добрый день. Помогите, пожалуйста, решить проблему.
Я не моделлер, но хотел бы узнать причину косяков при скиннинге.
Сделал себе lo poly персонажа. Normalmap запекся нормально. При запекании выставил Fill texture seams=4. В статике швов нет, модель выглядит адекватно.
Но при деформациях «обнажаются» швы в некоторых местах модели. Особенно проблематична область подмышек при поднятии руки вверх.
Можно ли избавиться от подобных пятен или хотя бы снизить их интенсивность?
 

Вложения

Skif

Администратор 3D галереи
Команда форума
Рейтинг
1 572
#2
скорее всего у вашей модели залочены нормали. это бывает если моделили в другом софте.хотя не только . зайти нормалс - анлок нормалс. если не поможет будем думать
 

Skif

Администратор 3D галереи
Команда форума
Рейтинг
1 572
#4
кстати это может быть глюк вьюпорта 2.0
 

Ro:nin

Активный участник
Рейтинг
15
#5
Отрендерил с помощью mentalray (материал mia_material_x). Пятна остались.
Ради любопытства открыл модель байкера из Digital Tutors - Rigging Game Characters in Maya 2011. Подмышки также глючат.
Сейчас я работаю в 2014 версии. Но такие же пятна были и в 12-13.
 

Skif

Администратор 3D галереи
Команда форума
Рейтинг
1 572
#6
хард еджи? не слиты вертексы? проблемы с текстурой?
 

Ro:nin

Активный участник
Рейтинг
15
#7
хард еджи? не слиты вертексы? проблемы с текстурой?
С этим все в порядке. Скачал пару моделей в инете. Сделал скин - тоже самый глюк, но швы обнажаются гораздо меньше. Навеное у меня косяки с топологией.
 

Yaroslav Abramov

Активный участник
Рейтинг
15
#8
мимо проходил, в ментале, а особенно на mia, при гамме отличной от 1 нормал мапы глючат безбожно
 
Сверху