1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Вопрос по Render to Texture..

Тема в разделе "Общие вопросы", создана пользователем SPY_JOHN, 30 июн 2009.

Модераторы: Артер
  1. SPY_JOHN

    SPY_JOHN Активный участник

    С нами с:
    08.04.2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    5
    Привет всем! Давно я мучаюсь с одной проблемой..Ответа в и-нете не нашел, возможно плохо искал, а возможно и его просто никто не поднимал. В общем, проблема в чем - не могу нормально отрендерить в текстуру, допустим тот же АО, не квадратные текстуры, например с соотношением 2:1, 1:4 и т.д., рендерит все равно в квадрат, хоть ты тресни. Рендерю АО через стандартный Ligth Tracer.
    Рендер почему игнорирует поля в Render To Texture -> Output -> Width/Height..
    Мне удавалось решить проблему при рендере через Vray. Там нужно было в модификаторе UnwrapUVW прописать соответствующее Высоту и Ширину в Render Height/Render Width, а потом в Render To Texture -> Output -> Width/Height соответствующие значения..

    А кто знает решение, если рендерить через Default Scanline Renderer c Ligth Tracer?
     
  2. AEplug

    AEplug Мастер

    С нами с:
    11.05.2005
    Сообщения:
    945
    Симпатии:
    66
    Баллы:
    152
    ну он их рендерит в квадрат а потом делает как надо - на диске с нужными пропорциями получается
     
  3. SPY_JOHN

    SPY_JOHN Активный участник

    С нами с:
    08.04.2008
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    5
    Да рендерит, только в пустом виде..Там вместо АО -альфа канал..=\
     
Модераторы: Артер

Поделиться этой страницей