1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Видеофайлы как текстура

Тема в разделе "Материалы, текстуры", создана пользователем alex hammer, 11 мар 2015.

Модераторы: Артер
  1. alex hammer

    alex hammer Активный участник

    С нами с:
    24.04.2009
    Сообщения:
    62
    Симпатии:
    21
    Баллы:
    9
    Некоторые видеофайлы ави, назначенные в качестве битмап, макс при прокручивании ползунка анимации не проигрывает. И при рендере (сингл фрэйм) рендерит первый кадр видео, независимо от положения ползунка на таймлайне. Этот глюк происходит как на объектах так и на бэкграунде. То есть если файл проигрывается, то и там и там, а если нет - то ни там ни там. Настройки все проверил. Свойства файлов ави посмотрел, различаются размером конечно, но делались все в максе при рендере разных сцен в разное время, однако ж, вот такой разный результат. Проверял все в одной сцене не меняя никаких настроек, просто тупо кидая авишки. Буду благодарен за подсказку.
     
  2. Deruz

    Deruz Знаток

    С нами с:
    06.10.2008
    Сообщения:
    2.070
    Симпатии:
    46
    Баллы:
    77
    Когда стоит видео, Макс априори "думает" что надо рендерить секвенцию, а не один кадр по середине. А не проигрывать может из за битрейта.
     
    alex hammer нравится это.
  3. alex hammer

    alex hammer Активный участник

    С нами с:
    24.04.2009
    Сообщения:
    62
    Симпатии:
    21
    Баллы:
    9
    Спасибо. Проверил по первой части вашего ответа. Если правильно понял, то при рендере в авишку все должно было заработать - не получилось, анимации видео на объекте не происходит, значит дело действительно в свойствах файлов. На скрине свойства трех файлов, крайний справа - не проигрывается. По тем свойствам что здесь указаны никакой зависимости не видно. Я в этом не знаток, но ави всегда делаю с настройками по умолчанию. только разные размеры. screenshot.1846.png Где еще искать различия?
     
  4. Royal Ghost

    Royal Ghost Мастер

    С нами с:
    17.03.2001
    Сообщения:
    306
    Симпатии:
    41
    Баллы:
    214
    Скорее проблема в кодеке .avi файлов.
     
  5. alex hammer

    alex hammer Активный участник

    С нами с:
    24.04.2009
    Сообщения:
    62
    Симпатии:
    21
    Баллы:
    9
    Да, опытным путем выяснил что не работает анимация с видео сделанным с помощью DV кодека, два других, установленных в максе - без компрессии и мпег работают нормально. Спасибо!
     
Модераторы: Артер

Поделиться этой страницей