1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Transfer attributes

Тема в разделе "Maya", создана пользователем Владимир Козин, 27 апр 2010.

Модераторы: Dark™, Skif
  1. Владимир Козин

    Владимир Козин Пользователь сайта

    С нами с:
    05.11.2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    2
    Господа, помогите начинающему. Как перейти в Standart Mode после перемещения UV по средствам Transfer attributes с полигональной модели на Subdivision surf? Вкладка в контекстном меню становится серой и не работает((( Пол дня по инету лазил, ответа нигде не нашел...
     
  2. DemX86

    DemX86 Знаток

    С нами с:
    04.09.2006
    Сообщения:
    615
    Симпатии:
    4
    Баллы:
    22
    Историю пробовал убивать?
    Еще там помнится надо при переходе из polygonal в standart не забыть выбрать что-то типа "наследовать uv" в channel editor в ноде полигональной, а то все правки UV не сохранятся.
     
  3. Владимир Козин

    Владимир Козин Пользователь сайта

    С нами с:
    05.11.2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    2
    Историю убивал, не помогло, переключение "взять UV с полигона тоже делал". Помоему надо как-то разъединить связь полигона и сабдива. Полигональная модель, связана с сабдивом, если ее удалить то и UV с сабдива слетают. Я учусь по одному уроку, там объяснение для Майа8, а у меня 2010. Вместо Transfer - transfer attribute...
     

    Вложения:

    • 1761872.jpg
      1761872.jpg
      Размер файла:
      178,7 КБ
      Просмотров:
      74
  4. Владимир Козин

    Владимир Козин Пользователь сайта

    С нами с:
    05.11.2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    2
    View Full Version : Maya 2009: Problems transfering UVs from poly model to subD model
    cynicalbug
    01-22-2010, 08:42 AM
    I'm working on maya 2009 and am coping with the loss of the Copy Mesh Attributes option that was available in earlier versions.

    I have been attempting to transfer a poly UV to SubD model using the Transfer Attributes and the end result is the UVs transfer properly but I am left with an extra polygon cage that is somehow attached to the subD model.

    Here are my steps.

    1. Duplicated the subD model and converted the duplicate to polygon model.
    Tesselation Method: Verticies.

    2. Mapped UVs on the polygon Model.
    3. Enter polygon mode on the SubD model.
    4. Select poly model with "good" UVs, shift selected subD model.
    5. Went to the Transfer Attributes options.
    6. set transfer UVs to 'All'.
    7. set sample source to 'component', all other options are on default.
    8. selected 'Apply'.

    The UVs transfer, set subD model to "inherit UVs". UVs appear correctly but I can no longer go back to 'Standard' mode on the subD model. Cleared history on SubD model. The model returns to 'Standard' mode but the polygon cage remains.

    Entered 'Face' mode while in "standard" mode. Selected all faces and moved the model. The model moved outside of the polygon cage. When I enter "polygon" mode again, a second polygon cage appears on the subD model... I think I'm going insane at this point. Any help would be awesome.

    See images below.

    http://i80.photobucket.com/albums/j200/rynoth/polycage.jpg

    http://i80.photobucket.com/albums/j200/rynoth/polycage2.jpg
     
  5. Skeptis

    Skeptis Активный участник

    С нами с:
    28.08.2012
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    9
    У меня та же проблема, не могу правильно перенести UV c поли на сабдив. По тому же самому уроку :(
    Но я уже понял откуда происходят корни данной проблемы не могу разобраться? как решить. Может кто что- нибудь посоветует. Итак мой порядок действий и сама проблема:
    1. Дана модель из собдивов (тело динозавра).
    2. Для UV развертки сделал копию и перевел в полигональный объект.
    3. У копии удалил половину (Как я понял в этом и проблема).
    4. Сделал UV развертку.
    5. Сделал MirrowGeometry.
    6. Беру исходную сабдив модель и включаю ее в режим полигонов.
    7. Делаю Transfer attributes для UV.
    8. Inheirt UV from poly в свойствах сабдив модели.
    9. В UV едиторе вижу правильные ювишки а во вьюпорте наблюдаю неправильное наложение текстуры.
    10. WTF??- спросил себя я и решил проверить перенесутся ли ювишки корректно на полигональную копию моей сабдивной модели. Пробую и тот же результат.
    11. Удаляю половину у своей второй копии (той которой еще без ювишек), делаю мирров, пробую перенести и все отлично перенеслось. Т.е. дело именно в том что я разрезал полигональную копию модели :(
    Как мне после всех этих манипуляций добиться правильного отображения текстуры на сабдив модели?
    P.S. количество вершин на всех моделях одинаковое.
     

    Вложения:

    • 2964747.jpg
      2964747.jpg
      Размер файла:
      751,2 КБ
      Просмотров:
      75
  6. Skeptis

    Skeptis Активный участник

    С нами с:
    28.08.2012
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    9
    хе-хе, приехал домой, сам разобрался :) При применении Transfer attributes нужно выставлять такие параметры:
     

    Вложения:

    • 2965222.jpg
      2965222.jpg
      Размер файла:
      657,3 КБ
      Просмотров:
      80
Модераторы: Dark™, Skif

Поделиться этой страницей