1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Проблема установки LuxRender

Тема в разделе "Blender3D", создана пользователем Lev Kononov, 7 янв 2011.

Модераторы: logosman
  1. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    хочу установить luxrender на blender 2.56 beta. при установке вылазит такая вот ошибка. в чем проблема то? пифон не тот?
    вот тут расписано что нужно делать http://www.luxrender.net/v/exporter_blender
    но папки .blender на жестком диске нет и в помине
     

    Вложения:

    • 2101782.jpg
      2101782.jpg
      Размер файла:
      108,2 КБ
      Просмотров:
      121
    • 2101783.jpg
      2101783.jpg
      Размер файла:
      104,8 КБ
      Просмотров:
      130
  2. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    Похоже что эта инсталяция для Б-2.49 была.
    Возьми плагин http://src.luxrender.net/luxblend25/archive/tip.zip и вставь содержимое в \Blender Foundation\Blender\2.56\scripts\addons\
    Запусти блендер и активируй аддон люксрендера.
    Для справки: http://www.luxrender.net/wiki/index.php?title=LuxBlend_2.5_installation_instructions
    http://www.luxrender.net/forum/viewtopic.php?f=11&t=4516
    Сам люкс можешь не инсталятором ставить, а просто архив скачать и распоковать. И уже в Блендере в настройках рендера просто укажешь путь к Luxrender.exe
     
  3. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    спасибо! вот что получилось. только не получается активировать: не ставится галочка.
    где это сделать?
     

    Вложения:

    • 2102272.jpg
      2102272.jpg
      Размер файла:
      200,1 КБ
      Просмотров:
      124
  4. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    просто один раз кликни в квадратик и жди. Галочка через несколько секунд появится.
    run renderer (см. скрин)
     

    Вложения:

    • 2102322.jpg
      2102322.jpg
      Размер файла:
      47,6 КБ
      Просмотров:
      123
  5. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    хоть убей - не ставится)
     
  6. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    может проблема в том, что я не туда закинул вышеупомянутый плагин? дело в том что я установил пользовательские файлы (users files) в ту же папку что и сам блэндер (по умалчиванию их установило бы в папку, путь к которой имел кириллицу)
     
  7. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    Похоже на баг. Сделай так. верни начальные настройки Блендера: File - Load Factory Settings
    Потом сохрани настройки Ctrl U
    Перезапусти Блендер и сразу активируй аддон.
     
  8. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    это тот аддон который нужен? просто когда я ставлю первоначальные установки и пытаюсь его инсталировать, пишет, что "file is alrady instaled to.." далее идет адрес аддона. фух, достал я вас)
     
  9. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    .
     

    Вложения:

    • 2103677.jpg
      2103677.jpg
      Размер файла:
      93,3 КБ
      Просмотров:
      133
  10. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    у меня нет таких проблем. Закинул папку luxrender из архива в папку addons, и всё работает. Может это потому что у меня ХР, а не семёрка как у тебя?
    Если уж совсем никак просто использую сборку Блендера с уже готовым аддоном(+ кучей других)
    http://www.graphicall.org/builds/builds/showbuild.php?action=show&id=1650
     
  11. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    огромное спасбо! сейчас пока нета, чтоб скачать, нет, но, надеюсь, все будет работать
     
  12. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    что это такое?
     

    Вложения:

    • 2108202.jpg
      2108202.jpg
      Размер файла:
      124,1 КБ
      Просмотров:
      128
  13. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    Какая-то ошибка в превью материала. Читай что в консоли пишет.
    Советую сюда обратится за помощью http://blender3d.org.ua/forum/rendering/80.html Там есть SATtva - специалист по Люксу (один из разработчиков). Он постоянно на оф. форуме люксрендера тусуется, в курсе всех проблем и решений. Я думаю он не откажет в помощи.
    Он здесь тоже зарегистрирован: http://render.ru/user/info.php?user_id=119279
    У меня таких ошибок пока что ещё не выплывало.
    :)
     
  14. SATtva

    SATtva Пользователь сайта

    С нами с:
    31.07.2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    2
    Значительная часть функционала ЛюксБленда 2.5 (включая превью материалов) требует модуль pylux. Скачать его более-менее свежую версию можно в составе готового билда Блендера с graphicall, либо самую свежую версию непосредственно с официального сайта Люкса, из раздела тестовых сборок: http://www.luxrender.net/forum/viewforum.php?f=30

    Прошу обратить внимание: ЛюксБленд 2.5 (как и сам Блен 2.5) находится в активной разработке, его поддержка оказывается в ограниченном режиме.
     
  15. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    ну так у меня как раз и стоит билд http://www.graphicall.org/builds/builds/showbuild.php?action=show&id=1650, а люкс http://www.luxrender.net/forum/viewforum.php?f=30.
    потом я указал путь к ехе файлу люкса и вот... вышеупамянутая ошибка
     
  16. dengess

    dengess Знаток

    С нами с:
    23.02.2007
    Сообщения:
    1.043
    Симпатии:
    9
    Баллы:
    46
    А в пути небыло русских букв?
     
  17. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    нет, все папки лежат прямо на С:\
     
  18. SATtva

    SATtva Пользователь сайта

    С нами с:
    31.07.2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    2
    Архитектура сборок Блена и pylux'а совпадают? Если Блен 32-битный, то и pylux должен быть аналогично.
     
  19. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    да вроде все как надо: LuxRender_0.7.1_32_SSE2 и Blender 2.56a (trunk) rev34281 32bit + patches + contrib & external add-ons + API Doc.
    В папке с luxrender есть папки pithon 2 и pithon 3. С лежащими в них файлами (pylux.pyd) ниче не надо делать?
     
  20. Lev Kononov

    Lev Kononov Знаток

    С нами с:
    01.09.2007
    Сообщения:
    534
    Симпатии:
    5
    Баллы:
    62
    может быть посоветуете альтернативу LuxRender?
     
Модераторы: logosman

Поделиться этой страницей