1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

проблема с Render elements

Тема в разделе "Визуализация", создана пользователем Чеширка_, 7 авг 2015.

Модераторы: Артер
  1. Чеширка_

    Чеширка_ Пользователь сайта

    С нами с:
    07.08.2015
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    2
    Здравствуйте!

    Рендерю сцену, нужны некоторые Render elements (в частности, VRayDiffuseFilter и VRayLighting). F10 -> Render elements -> Add. Указала папки сохранения. И никак не могу понять почему, но после рендера (буфер максовский) у меня не появляются окошки с картинками включенных элементов рендера. Когда использую буфер vray, то кроме альфа канала и rgb color в выпадающем списке (левый верхний угол окошка рендера) тоже больше ничего нет. Указывала папки, куда нужно сохранять эти элементы рендера, но и папки пустые. Галочка Save separate render channels стоит, путь указан. Подскажите, пожалуйста, в чём может быть проблема?

    Заранее спасибо!
     
  2. Ayfat

    Ayfat Знаток

    С нами с:
    09.02.2007
    Сообщения:
    545
    Симпатии:
    66
    Баллы:
    31
    Какая версия вирея? Вообще начиная как минимум с 2.4 в виреевский фреймбуффер элементы добавляются сразу после того как вы их добавили в список. Никаких дополнительных действий не нужно. Они даже во время рендера доступны. Если вирееский фреймбуффер отключен - элементы появляются в отдельных окошках в максовском, уже после рендера.
     
  3. Чеширка_

    Чеширка_ Пользователь сайта

    С нами с:
    07.08.2015
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    2
    Макс 2013 х64
    VRay 2.30

    Окошки не появляются без виреевского фреймбуфера. И с ним тоже нет в списке того, что нужно. Есть только стандартне rgb colors и альфа канал(((
     
  4. Ayfat

    Ayfat Знаток

    С нами с:
    09.02.2007
    Сообщения:
    545
    Симпатии:
    66
    Баллы:
    31
    У меня, увы, нет вирея 2.30, но на 2.40 все работает "из коробки", и на 2.30 все скорее всего также. Попробуйте открыть пустую сцену, нарисовать шарик и виреевский светильник рядом с ним. Включите GI IM+LC все со стандартными настройками. В рендер элементы добавьте какие-нибудь GlobalaIllumination и Lighting. Нажмите рендер - оно отрендерится и появится несколько окошек с элементами. Включите виреевский фреймбуффер, еще раз отрендерите - элементы должны быть в списке. Если все работает как я описал - проблема в настройках вашей сцены. В таком случае самый простой способ это исправить - сбросить настройки (меняете рендер на Default Scanline, а затем обратно на вирей).
     
  5. Чеширка_

    Чеширка_ Пользователь сайта

    С нами с:
    07.08.2015
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    2
    Проблему решила))
    Оказывается, нужно в окошке Render Elements выставлять галочки возле Elements Active и Display Elements.
    Всем спасибо)
     
Модераторы: Артер

Поделиться этой страницей