1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

ошибка внедрения RAT в Maya 3

Тема в разделе "RenderMan", создана пользователем -, 15 ноя 2000.

Модераторы: Moderator.
  1. Guest

    1.
    Хочу прикрутить к "Майке" v3.0 05/24/2000
    RAT v4.1b1, но когда я пытаюсь загрузить ее плугины
    на mtor.dll выдается ошибка:
    Maya 3.0. Entry Point Not Found
    The procedure entry point?getUVIndex@MltMeshPolygon@@QAE?AVMStatus@@HAAH@Z could not be located in the dynamic link library OpenMaya.dll
    в статусной строке Error: No plug-ins loaded - "The specified procedure could not be found.

    а на mtorsubdiv.dll
    Error: No plug-ins loaded - "Plug-in, "mtorsubdiv" was compiled against too old a version of the Maya API and is thus incompatible with the current Maya version. Obtain a newer version of this plug-in.".

    PS: Причем тестовый пример в RAT/etc/setup рендерится нормально.

    2. Еще вопрос как адаптировать RAT к Rhino3D
     
  2. Guest

    RAT v4.1b1 ? Это, наверное, бета какая-нибудь... Надо релиз ставить.
     
  3. Guest

    RAT v4.1b1 и все остальные беты скомпилены только под 2.5 маю. Под 3 майкой работает только релиз (714 или 717) для 3 маи (учти, что есть релиз скомпиленый под 2.5 маю). По моим наблюдениям надежность RAT под 3 маю оставляет желать лучшего. А вот под 2.5 маей еще релиз кандидат работал очень хорошо.
    Что касается тестового примера, то он не относится к RATу а тестирует только правильность установки Rendermanа.
     
  4. Guest

    Решается путем замены РАТ с 4.1.b1 на 4.1.1. Качай с родного сайта. Линк есть выше в конфе. Работает со старой лицензией от 4.1.b1. Только для начала деинсталь старый РАТ. Насчет траблов не знаю поскольку сам только нашел РАТ и поставил. Приниаются любые советы по началу работы с ним.
     
Модераторы: Moderator.

Поделиться этой страницей