1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Maya 5.0 for Linux - ошибка при запуске

Тема в разделе "Maya", создана пользователем -, 10 янв 2005.

Модераторы: Dark™, Skif
  1. Guest

    при попытке запуска выдаёт ошибку:

    [eugrus@eugrus bin]$ maya
    /usr/aw/maya5.0/bin/maya.bin: relocation error: /usr/aw/maya5.0/lib/libFoundation.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

    ставил пакеты AWCommon-5.3-5.i686.rpm и Maya5_0-5.0-18.i686.rpm

    предлагалось также скопировать libGLU.so но эта библиотека у меня уже есть и заменять я её не стал

    уже установлен openmotif-2.2.2-14

    может ему нужен GLIB 2.0?

    посмотрел сейчас 'rpm -qa | grep glib'
    вот вывод:
    glib-1.2.10-10
    glibc-kernheaders-2.4-8.10
    glib-devel-1.2.10-10
    glibc-common-2.3.2-11.9
    glib2-2.2.1-1
    glibc-devel-2.3.2-11.9
    glibc-2.3.2-11.9
    glib2-devel-2.2.1-1

    я так понимаю, что у меня стоят GLIB 1.2 и GLIB 2.2
     
  2. veent

    veent Знаток

    С нами с:
    07.12.2004
    Сообщения:
    383
    Симпатии:
    0
    Баллы:
    34
    Зайди в /usr/local/bin и в файлике @maya, вначале, пропиши:

    setenv LD_ASSUME_KERNEL 2.4.1

    должно помочь !
     
  3. Guest

    огромное спасибо!

    помогло
     
  4. Guest

    На ядре 2.6 этот способ не работает.

    Как это решить без апгрейда майи? Новую версию нет желания качать.
     
Модераторы: Dark™, Skif

Поделиться этой страницей