1. Пользоваться форумом на планшетах и телефонах стало удобнее благодаря Tapatalk

Maya 4.5 for linux: unresolved symbol

Тема в разделе "Maya", создана пользователем strait, 26 окт 2004.

Модераторы: Dark™, Skif
  1. strait

    strait Активный участник

    С нами с:
    13.12.2004
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    7
    Сорри за несколько неактуальный влпрос. Проблема в этом:
    /usr/aw/maya4.5/bin/maya.bin: error while loading shared libraries: /usr/aw/maya4.5/lib/libTranslators.so: undefined symbol: __dynamic_cast_2

    Ума не приложу чего ему не хватает...

    Сейчас у меня Gentoo (раньше пробовал под Debian таже ошибка), причем 5 версия работает без проблем, но полскольку машинка у меня не фонтан, хочу поставить менее "грузящюю" версию.
    Пробовал 4.0.1 - тоже неможет разрезолвить, но уже в другой либе (libFundation.so)

    может кто у кого получилось запускать эту версию откликнится ?
     
  2. Guest

    запускаешь csh говоришь
    set LD_ASSUME_KERNEL = 2.4.1
    Далее запускаешь maya в этой же консоле.
    Если это помогло прописываешь в скрипт запуска маи (/usr/aw/maya/bin/maya)
    в блоке case Linux
     
  3. strait

    strait Активный участник

    С нами с:
    13.12.2004
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    7
    Непомогло :(
    P.S. а что делает жта переменная ?
     
  4. Guest

    Хорошо, а как ты запускал маю после вода переменной?
    Из тойже консоли и таким образом (/usr/aw/maya4.5/bin/maya)?
    Если так, то тебе нужны compat либы, типа compatdb
    Удачи и всех благ.
    PS Поставь Fedore Core 2 мой тебе совет.
     
  5. strait

    strait Активный участник

    С нами с:
    13.12.2004
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    7
    Чертовщина какя-то, они у меня стояли давно....
     
  6. strait

    strait Активный участник

    С нами с:
    13.12.2004
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    7
    http://www.yaromenok.org/programming/prg/t10m/maya_on_non_redhat/maya_self_build_linux.html

    это оказывается сама майка так скомпилина...только под red-hat libstd++
     
  7. Guest

    Поищи в этом же форуме мой пост по поводу установки под Слаку. Может поможет.
     
  8. strait

    strait Активный участник

    С нами с:
    13.12.2004
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    7
    Спасибо, но предыдущее высказывани (там где линк) и есть решение проблемы.
     
Модераторы: Dark™, Skif

Поделиться этой страницей